how to turn off shading and display wireframe.

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
IFish4Tuna
Posts: 3
Joined: Sat Jan 04, 2014 4:01 pm

how to turn off shading and display wireframe.

Post by IFish4Tuna »

Hello -

I am looking for some help on setting the view to be wire frame without shading for submission to the US Patent office.
My drawings were rejected due to the shading. They only want black and white. I do not want to see hidden lines when displaying/printing. I only want to show the data that is facing based upon perspective.

I can not seem to figure out how to set the viewing to be wire frame based.

I looked in the documentation, and could not find any suggestions.

Thanks, Ed
User avatar
NormandC
Veteran
Posts: 18587
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: how to turn off shading and display wireframe.

Post by NormandC »

Hello Ed,

Welcome here. The first thing you should do is read the "Read first before asking for help!!!" topic that is second in the list. This post explains what you need to provide to get the most efficient help.

On syntax, by definition wireframe shows every edges, including the hidden lines.

You cannot get what you want from the 3D view. To get a view in black and white with hidden lines off, you need to create a projected view of your 3D model. For that you will use the Drawing workbench.
wmayer
Founder
Posts: 20113
Joined: Thu Feb 19, 2009 10:32 am
Contact:

Re: how to turn off shading and display wireframe.

Post by wmayer »

This is a rendering mode that is not directly available. However, with some changes in your user settings you can simulate this effect. Here are the steps:

1. Set the display mode of the shape to Flat Lines (Yes, Flat Lines!)
2. Set the shape color of the part to black
3. Set the line color of the part to white
4. Now go to the preferences (Edit > Prefs > Display > Colors) and set the background color to black

Now you have black and white and you don't see hidden lines.
User avatar
bejant
Veteran
Posts: 6075
Joined: Thu Jul 11, 2013 3:06 pm

Re: how to turn off shading and display wireframe.

Post by bejant »

wmayer wrote:1. Set the display mode of the shape to Flat Lines (Yes, Flat Lines!)
2. Set the shape color of the part to black
3. Set the line color of the part to white
4. Now go to the preferences (Edit > Prefs > Display > Colors) and set the background color to black
Gives me this:
20140104a_Black_and_White.jpg
20140104a_Black_and_White.jpg (19.02 KiB) Viewed 9110 times
So right-click on the object in the tree view:
2. Shape color = White
3. Line color = Black
and in the Material section of the Display Properties window click the little box with three dots next to Default aqnd change all four colors to white. I left shininess at the default 20% and got this:
20140104b_Black_and_White.jpg
20140104b_Black_and_White.jpg (17.95 KiB) Viewed 9110 times
It's pretty close but how to see the curved edges?

Edit:
OS: Ubuntu 12.04.3 LTS
Platform: 32-bit
Version: 0.14.2911 (Git)
Branch: master
Hash: a2cba17d3f2faf44188298eb16211f7b6bc45358
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
Attachments
20130101a_Tripod.fcstd
(20.74 KiB) Downloaded 96 times
User avatar
NormandC
Veteran
Posts: 18587
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: how to turn off shading and display wireframe.

Post by NormandC »

Interesting trick, I didn't know it. But I still think it's much simpler to use the Drawing workbench.

Although bejant's file displays with errors.
Attachments
FC_Drawing_workbench_tripod.png
FC_Drawing_workbench_tripod.png (174.97 KiB) Viewed 9109 times
User avatar
NormandC
Veteran
Posts: 18587
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: how to turn off shading and display wireframe.

Post by NormandC »

bejant wrote:It's pretty close but how to see the curved edges?
Those are called "silhouette edges" and I don't think FreeCAD can display them in the 3D view because they don't really exist.

Which goes back to what I've been saying from the start... ;)
User avatar
bejant
Veteran
Posts: 6075
Joined: Thu Jul 11, 2013 3:06 pm

Re: how to turn off shading and display wireframe.

Post by bejant »

normandc wrote:Which goes back to what I've been saying from the start.
Before my other post I started playing around with the Drawing workbench as you advised the OP but got the same results with my file as you did. I didn't bother to post that because I didn't think it was helpful.
User avatar
NormandC
Veteran
Posts: 18587
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: how to turn off shading and display wireframe.

Post by NormandC »

Even not knowing what type of shape Ed is working on, I still believe what I've been advocating is the best bet. There seems to be something odd with your model, I've never seen unwanted artifacts such as this line that crosses the page in any projected view I've made.

The Drawing view option has also another advantage: you can get a vector file out of it either in DXF or SVG format, so you can edit it to correct any oddities. That would be a lot harder on a bitmap image, which the only thing you can get out of a screen capture of your 3D view.
User avatar
NormandC
Veteran
Posts: 18587
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: how to turn off shading and display wireframe.

Post by NormandC »

I forgot about another option: the Draft Shape2DView tool. It does create a correct 2D projection in the 3D view. All that is needed is to change the background to white.
FC_Tripod_Shape2DView.png
FC_Tripod_Shape2DView.png (5.21 KiB) Viewed 9104 times
Attachments
20130101a_Tripod_Shape2DView.fcstd
(24.14 KiB) Downloaded 87 times
User avatar
quick61
Veteran
Posts: 3803
Joined: Sat Aug 24, 2013 2:49 am
Location: u.S.A.

Re: how to turn off shading and display wireframe.

Post by quick61 »

Normand posted while I was in FreeCAD and before I got a chance to post this -
Black_and_White.png
Black_and_White.png (34.27 KiB) Viewed 9102 times
Normand, change the angle of the iso view and that line will go away. (one of the little bugs still in the drawing workbench me thinks) I tweaked the angle of the one in this file and it came out OK. Yea, the draft shape 2D view works too.
Black_and_White.svg
(27.02 KiB) Downloaded 247 times
This post made with 0.0% Micro$oft products - GOT LINUX?
Post Reply