help for Modelling

Post here for help on using FreeCAD's graphical user interface (GUI).
Forum rules
and Helpful information
IMPORTANT: Please click here and read this first, before asking for help

Also, be nice to others! Read the FreeCAD code of conduct!
jaisejames
Posts: 384
Joined: Sat Sep 24, 2016 6:51 am

help for Modelling

Post by jaisejames »

I was trying to do Axial fan. but revolve is not coming correcting. Sectional View and details are there in pdf file

Free cad details

OS: Windows XP
Word size of OS: 32-bit
Word size of FreeCAD: 32-bit
Version: 0.16.6700 (Git)
Build type: Release
Branch: releases/FreeCAD-0-16
Hash: 7b925d11aa69ac405b423635adb1e2833f18a817
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Attachments
fan.png
fan.png (194.24 KiB) Viewed 1799 times
Fan Details.pdf
(133.76 KiB) Downloaded 30 times
Fan.FCStd
(24.49 KiB) Downloaded 33 times
User avatar
Willem
Veteran
Posts: 1852
Joined: Fri Aug 12, 2016 3:27 pm
Location: Lisse, The Netherlands

Re: help for Modelling

Post by Willem »

Revolving succeeds when you use the revolve function in the Part workbench instead of the revolve in the Part Design workbench
jaisejames
Posts: 384
Joined: Sat Sep 24, 2016 6:51 am

Re: help for Modelling

Post by jaisejames »

I used part work bench only. but revolving circles shows as lines instead of torus solid.
User avatar
Willem
Veteran
Posts: 1852
Joined: Fri Aug 12, 2016 3:27 pm
Location: Lisse, The Netherlands

Re: help for Modelling

Post by Willem »

I do not know what happened. I deleted your revolution and it looked wrong, I created a new one and everything is good. Perhaps it is that you do not have the most recent Freecad version. My specs are

OS: Ubuntu 16.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6707 (Git)
Build type: None
Branch: releases/FreeCAD-0-16
Hash: 5465bc47c95db45e0be85dc0e2872419efadce0f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Attachments
Fan_Willem.FCStd
(24.19 KiB) Downloaded 24 times
jaisejames
Posts: 384
Joined: Sat Sep 24, 2016 6:51 am

Re: help for Modelling

Post by jaisejames »

Thanks for support. I checked your attached file it is showing correcting. when ever I do, it is showing lines. Even I tried with draft circle, same result. I will try with 6706 version.

In between I have notice that circle join dot should be parallel to direction to Z. if not, it will look bump like surface.

Thanks for support.
User avatar
bejant
Veteran
Posts: 6075
Joined: Thu Jul 11, 2013 3:06 pm

Re: help for Modelling

Post by bejant »

Willem wrote:Revolving succeeds when you use the revolve function in the Part workbench
@Willem, that is what jaisejames used (maybe you just typed it incorrectly?).

@jaisejames, the problem is that although the Revolve worked, it doesn't render correctly in the 3D view. To fix it, go to Edit > Preferences > Part Design (icon in left pane) > Shape view (tab) and change the Maximum deviation... setting to something like .1 or less. The smaller you make the value the smoother your model will appear but it will take longer for your computer to process the image, so for other models you might want to change it back to the default setting of 0.5.
jaisejames
Posts: 384
Joined: Sat Sep 24, 2016 6:51 am

Re: help for Modelling

Post by jaisejames »

Thanks it is working now. I changed to 0.1.

I need to create U shape or half torus at the end of sweep rod on both end & attached to face[as in attachment]. I tried with sketch face with linked edge option. But circle become flat on revolve. It is creating flat ring than half torus. Any Idea how to create attached half rings on end of rods.
Attachments
sample.png
sample.png (148.36 KiB) Viewed 1716 times
User avatar
NormandC
Veteran
Posts: 18587
Joined: Sat Feb 06, 2010 9:52 pm
Location: Québec, Canada

Re: help for Modelling

Post by NormandC »

FYI, even if the "Solid" property of Revolve is set to true, it didn't create solid rings. As can be seen from Part CheckGeometry, Revolve is a compound composed of 25 shells, and zero solid.

Apparently, the Revolve tool cannot create solids from an object containing multiple separate closed profiles like the PathArray or even a Sketch.

This is odd, because there is no such problem with the Part Extrude tool, which can create multiple solids under a single Extrude object.

This may very well be a bug with Part Revolve.
jaisejames
Posts: 384
Joined: Sat Sep 24, 2016 6:51 am

Re: help for Modelling

Post by jaisejames »

My requirement is dia of torus 3mm & inner dia is 60m & gap between torus is 16mm. It keep on increase until say 400mm as shown.

Any other way to create valid solid?
User avatar
Willem
Veteran
Posts: 1852
Joined: Fri Aug 12, 2016 3:27 pm
Location: Lisse, The Netherlands

Re: help for Modelling

Post by Willem »

Hi, it is difficult to create solid torusses, I downgraded the array twice in the draft workbench, than you have 25 edges for the 25 circles as a base for the torusses. When I revolve those edges individually they still are not solid. The only way it succeeds is when you draw new circles in the draft workbench with the center of the edges selected. Revolving these circles create solids

About your previous question: Did you succeed in connecting the two headerlines or is this animation still valuable
animatie-2.gif
animatie-2.gif (811.25 KiB) Viewed 1700 times
Post Reply