Assembly 4 Workbench issues

Discussion about the development of the Assembly workbench.
Post Reply
WS222
Posts: 7
Joined: Sun Nov 13, 2022 3:53 pm

Assembly 4 Workbench issues

Post by WS222 »

Hi Gents,

finally I decide to use Assembly Workbench 4 to check my parts before I order lasercut.
Beginning was promising until a modification in one of the parts (center frame side) and now all parts become invisible.
Unbenannt.JPG
Unbenannt.JPG (128.43 KiB) Viewed 404 times
Project can be found here:

https://www.dropbox.com/scl/fo/mc724wqb ... 0ib0cqvsyp

Thanks in advance

Winfried

System: Win10
Assembly4: v0.12.4
ladis
Posts: 24
Joined: Mon Mar 08, 2021 10:53 am

Re: Assembly 4 Workbench issues

Post by ladis »

Indeed. Is there anything to prevent you from using newer version? Your model seems to be fine in 0.20.1. Assembly4 workbench v0.12.4 used for both Freecad 0.19.1 and 0.20.1
User avatar
Zolko
Veteran
Posts: 1993
Joined: Mon Dec 17, 2018 10:02 am

Re: Assembly 4 Workbench issues

Post by Zolko »

WS222 wrote: Fri Nov 18, 2022 7:05 pm Beginning was promising until a modification in one of the parts (center frame side) and now all parts become invisible.
it's a 2.10m wingspan Horten. What aerodynamical design (airfoils, sweep and twist) do you use for it ?

Horten.png
Horten.png (416.97 KiB) Viewed 272 times

It opens correctly in v0.21, but not with v0.19. More importantly, you have a circular reference somewhere (Document::getDependentDocuments: The graph must be a DAG), and apparently v0.21 can handle it even though there is an error, while v0.19 can't. You should nook where this circular dependency comes from (Part A depending on Part B depending in Part C depending on Part A)

Also, you don't have to wrap each PartDesign Body (blue icon) into a Std_Part (yellow icon), you can – and should – use the PartDedign Bodies directly.
try the Assembly4 workbench for FreCAD
install with Tools > Addon Manager > Assembly4 — tutorials here and here
Post Reply