[solved] Can't run buckling analysis in 0.20

About the development of the FEM module/workbench.

Moderator: bernd

NewJoker
Veteran
Posts: 1333
Joined: Sun Oct 11, 2020 7:49 pm

[solved] Can't run buckling analysis in 0.20

Post by NewJoker »

Hi,

previously, when I was trying to submit the analysis in 0.20, I was receiving "No CalculiX binary ccx" error each time: https://forum.freecadweb.org/viewtopic.php?f=18&t=60951

Now in the newest weekly build there's no such issue but I can't run buckling analysis successfully and it happens on 2 different computers. There's no pop-up window with error message, just some red-colored output in the Report View:

error.JPG
error.JPG (59.37 KiB) Viewed 1486 times

and FreeCAD hangs completely (I have to kill it with Task Manager).

I also tried running this type of analysis with "Solver CalculiX (new framework) and it completes but the results seem empty.

OS: Windows 10 Version 2009
Word size of FreeCAD: 64-bit
Version: 0.20.25541 (Git)
Build type: Release
Branch: master
Hash: ca043dcb6d20d70b8e24d75e810683214eecc5d4
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.0
Locale: Polish/Poland (pl_PL)
thschrader
Veteran
Posts: 2685
Joined: Sat May 20, 2017 12:06 pm
Location: Germany

Re: Can't run buckling analysis in 0.20

Post by thschrader »

I get this with
beullast_zylinder.FCStd
(14.35 KiB) Downloaded 29 times

OS: Windows 10 Version 1909
Word size of FreeCAD: 64-bit
Version: 0.20.25541 (Git)
Build type: Release
Branch: master
Hash: ca043dcb6d20d70b8e24d75e810683214eecc5d4
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.0
Locale: German/Germany (de_DE)
buckle_cylinder.JPG
buckle_cylinder.JPG (73.54 KiB) Viewed 1437 times
cad1234
Posts: 299
Joined: Fri Dec 28, 2018 11:11 am

Re: Can't run buckling analysis in 0.20

Post by cad1234 »

@Thomas
The same here..

OS: Windows 10 Version 2004
Word size of FreeCAD: 64-bit
Version: 0.20.25541 (Git)
Build type: Release
Branch: master
Hash: ca043dcb6d20d70b8e24d75e810683214eecc5d4
Python version: 3.8.6+
Qt version: 5.15.2
Coin version: 4.0.1
OCC version: 7.5.0
Locale: German/Germany (de_DE)
Attachments
buckling-test.jpg
buckling-test.jpg (559.34 KiB) Viewed 1422 times
User avatar
bernd
Veteran
Posts: 12536
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Can't run buckling analysis in 0.20

Post by bernd »

cad1234 wrote: Fri Sep 03, 2021 8:11 am @Thomas
The same here..
this is a totally different error not related to buckling at all. You would need to post the file to make us find the problem. But since it is a different problem make a new topic.
User avatar
bernd
Veteran
Posts: 12536
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Can't run buckling analysis in 0.20

Post by bernd »

NewJoker wrote: Thu Sep 02, 2021 4:26 pm Hi,

previously, when I was trying to submit the analysis in 0.20, I was receiving "No CalculiX binary ccx" error each time: https://forum.freecadweb.org/viewtopic.php?f=18&t=60951

Now in the newest weekly build there's no such issue but I can't run buckling analysis successfully and it happens on 2 different computers. There's no pop-up window with error message, just some red-colored output in the Report View:


error.JPG


and FreeCAD hangs completely (I have to kill it with Task Manager).

I also tried running this type of analysis with "Solver CalculiX (new framework) and it completes but the results seem empty.
it seams this is a problem of the calculix binary and not inside FreeCAD. ccxtools and calculix new solver framework eventually use the same ccx binary. See this topic suggested links.
User avatar
bernd
Veteran
Posts: 12536
Joined: Sun Sep 08, 2013 8:07 pm
Location: Zürich, Switzerland

Re: Can't run buckling analysis in 0.20

Post by bernd »

We should get rid of this. Would you report back if you succeeded with a alternate ccx binary? Which FreeCAD did you download?
cad1234
Posts: 299
Joined: Fri Dec 28, 2018 11:11 am

Re: Can't run buckling analysis in 0.20

Post by cad1234 »

bernd wrote: Fri Sep 03, 2021 10:33 am
this was only meant as confirmation about what Thomas wrote, with my local computer..
I used his file beullast_zylinder, started buckling and had the same messages as thomas...
also with "INTEL MKL ERROR: Das angegebene Modul wurde nicht gefunden. mkl_intel_thread.dll. "
and the message about Nodecount
Last edited by cad1234 on Fri Sep 03, 2021 11:34 am, edited 2 times in total.
NewJoker
Veteran
Posts: 1333
Joined: Sun Oct 11, 2020 7:49 pm

Re: Can't run buckling analysis in 0.20

Post by NewJoker »

bernd wrote: Fri Sep 03, 2021 10:38 am We should get rid of this. Would you report back if you succeeded with a alternate ccx binary? Which FreeCAD did you download?
I tried using ccx_PARDISO downloaded from the CalculiX's homepage (newest release), placed in FreeCAD's bin folder and selected in Preferences --> FEM --> CalculiX --> CalculIX binary but I got errors saying: "FEM: wrong ccx binary", "FEM: CalculiX binary ccx ... not found. Please set the CalculiX binary ccx path in FEM preferences tab CalculiX" and "CalculiX has not been run. The CalculiX binary search returned: False.".

To get the newest FreeCAD weekly build I downloaded this file:
https://github.com/FreeCAD/FreeCAD-Bund ... -x86-64.7z
User avatar
johnwang
Veteran
Posts: 1128
Joined: Sun Jan 27, 2019 12:41 am

Re: Can't run buckling analysis in 0.20

Post by johnwang »

Got result with:

Code: Select all

OS: Windows 10 (10.0)
Word size of FreeCAD: 64-bit
Version: 0.21.29485 (Git)
Build type: Release
Branch: master
Hash: a236ca843fdd6674afb6d7ed1454fbd3b547f5ea
Python 3.8.13, Qt 5.12.9, Coin 4.0.0, Vtk 9.1.0, OCC 7.5.3
Locale: English/United States (en_US)
So, no problem now?
ba.png
ba.png (27.04 KiB) Viewed 380 times
hfc series CAE workbenches for FreeCAD (hfcNastran95, hfcMystran, hfcFrame3DD, hfcSU2 and more)
User avatar
uwestoehr
Veteran
Posts: 4407
Joined: Sun Jan 27, 2019 3:21 am
Location: Germany

Re: Can't run buckling analysis in 0.20

Post by uwestoehr »

NewJoker wrote: Thu Sep 02, 2021 4:26 pm OS: Windows 10 Version 2009
Word size of FreeCAD: 64-bit
Version: 0.20.25541 (Git)
This is not FreeCAD 0.20.0 final. You must use at least this version.

In your error message you also see that an outdated LibPack was used. This had some issues with third-party libraries like CCX and others.

-----------

FC 0.20.1 will come out this week and comes with massive fixes for FEM.
Post Reply